Ach ne! Kde je JavaScript?
Váš webový prohlížeč nemá povolen JavaScript nebo nepodporuje JavaScript. Pro správné zobrazení tohoto webu nebo pro upgrade na webový prohlížeč, který podporuje JavaScript, povolte JavaScript ve webovém prohlížeči.
PHP-Fusion 9 Jádro
v9.03.00
Překlad CZ/SK
Pravidelně aktualizovaný
Demo
Testovat PHP-Fusion

upload vaccsich suborov

Poslední aktualizace před 5 dny
J
Ked chcem uploadovat v "Obsah > subory na stiahnutie" vacsie subory ako 2MB tak to nefunguje.
V "Obsah > Súbory na stiahnutie > Nastavenie" som si nastavil velkost na 150MB. Subory ale aj tak neviem pridat.
Po googleni som zistil, ze je potrebne upravit php.ini, tak som tak urobil
post_max_size = 150M
upload_max_filesize = 150M
A teraz to uz funguje.
Chcem sa len opytat, ci je lepsie to nastavit v php.ini (globalne) alebo to radsej nastavit v .htaccess
Kvido
Jde ti o upload downloadů, rozumím-li dobře?
Takže: Obsah/Downloady/Nastavení
Zde dej třeba změnit např. na:
Maximální velikost souboru: 1500 MB
Bude možno stahovat 15 G, což je dostačující, myslím.
na php.ini můžeš měnit pokud jsi na domácím localhostu, jiank musíš požádat svůj webhosting o navýšení.
V .htacces nedporučuji nic měnit.
J
Ano chcem uploadovat subory cez webove rozhranie phpfusion aby sa objavili v downloade pre uzivatelov.
Nastavit max. velkost cez web administraciu nestaci (ja osobne som to zmenil v php.ini) pretoze je to vlastny VPS a som root.
post_max_size = 150M
upload_max_filesize = 150M
Ale obecne by stacilo tie 2 riadky pridat do .htaccess a malo by to fungovat v ramci webu
Kvido
Zkus tedy v .htaccess:
php_value upload_max_filesize 150M

Pokud pak vyskočí hláška 500 - Interní chyba serveru , nemáte oprávnění nastavit tyto hodnoty pomocí .htaccess . Nutné pak se podívat na směrnici AllowOverride, zda má v nastavení All. Je-li totiž tato směrnice nastavena All, je v souborech povolena jakákoli směrnice, která má kontext .htaccess.

<Directory />
AllowOverride All
</Directory>


Jestli ti to není jasné, tak pro Tvého virtual host by mělo být v: /etc/apache2/sites-enabled/000-default.
A v něm je nutné pro zadaný web adresár povolit ten AllowOverride All a lépe i přidat parametre Options.
Takže možná tam máš:
<Directory /var/www/>
 Options Indexes FollowSymLinks MultiViews
 AllowOverride None
 Order allow,deny
 allow from all
 </Directory>

... a tedy změň na:
AllowOverride All

Po restartu Apache to bude všechno brát z .htacess
rum
Jenom test vložení přílohy. Nejde mi smazat.
Prosím smazat tento příspěvek.
Vypadá to, že už z toho nevybrousím.
Smutný
rum Připojili následující obrazek:
Obrázek nebyl nalezen Obrázek nebyl nalezen Obrázek nebyl nalezen
Vy můžete zobrazit všechny příspěvky v tomto fóru.
Vy nemůžete začít nový diskusní příspěvek v tomto fóru.
Vy nemůžete odpovědět v této diskusi.
Vy nemůžete začít v anketu v tomto fóru.
Vy nemůžete na tomto fóru nahrát přílohy.
Vy můžete stáhnout přílohy v tomto fóru.
Uživatelé, kteří se účastnili diskuse: Kvido, rum, jany
Nejnovější témata fóra
  Vlákno Zobrazení Odpovědi Poslední příspěvek
Farby uživateľov
v PHP-Fusion 9
100 0 xi3eat2
11-07-2019 20:16
upload vaccsich suborov
v Obecná diskuse
1132 4 rum
11-07-2019 07:45
Feedback
v PHP-Fusion 9
258 5 Balin50
22-06-2019 21:30
Administrácia adminov
v PHP-Fusion 9
209 1 RobiNN
22-06-2019 14:38
Súkromná správa
v Administrace obsahu
625 5 RobiNN
17-06-2019 17:14
Vodoznak
v Administrace obsahu
626 8 Balin50
31-05-2019 12:50
Related news panel PHP-Fusion 9
v PHP-Fusion 9
2379 7 RobiNN
28-05-2019 20:18