PHP min. 5.6.39MySQL min. 5.5.3Apache min. 2.4
PHP-Fusion 9 Jádro
v9.0
Český překlad
Pravidelně aktualizovaný - v9.0
PHP-Fusion 8 Jádro
v8.0
Český překlad
Pravidelně aktualizovaný - v8.0

zabezpečení registračního formuláře u7.02.06

Poslední aktualizace před 1 rokem
S
problém je v odesílaných e-mailech. Můj web na základě robotického vyplňování registračního formuláře spamuje e-mailové adresy, které tam ten robot zadá oznámeními o registraci a aktivaci účtu. V současné podobě stačí do toho formuláře opakovaně zadávat náhodné e-mailové adresy a Můj web na ně bude poslušně odesíla zprávy a protože ten formulář není zabezpečen, roboti vyplňují ten registrační formulář automaticky.
Já sice osobně potvrzuji registraci členů, ale ke spamování dochází už při žádosti o registraci.
Doporučíte mi zabezpečení Registračního formuláře? a popřípadě jak doplněk nainstalovat?
Jak má zabezpečený formulář PHP - Fusion 9?
Kvido
Ano, v. 7xx je na popisovaný problém děravá verze, Proto následuje v. 9xx, která má zabezpečení Registrace i e-mailového formuláře dokonalejší a i když nebyl ještě vydán Final verze, nezaznamenáváme u nás problémy.

Nejsem oprávněn sdělovat konkrétní zabezpečení, to je věc hlavních vývojářů, Chan, RobiNN, Falk...
Mohu jen naznačit, že e-mail může být zabezpečen v kódu třeba takto:

if(strstr($email, "\n") !== false || strstr($email, "\r") !== false) {
echo "Zeď proti hackerům a spamování";
exit;


Doporučuji přejít na verizi PHP-Fusion 9.0
RobiNN
Ak nechceš prejsť na novu deviatku tak aspoň odporúčam aktualizovať na 7.02.07. Registráciu zabezpečíš jednoducho, v nastaveniach bezpečnosti zapni captcha overovací kód.
S
na přeinstalaci se připravuji, mám v úmyslu přejít na novou verzi 9.
Kodování a programování je pro mě španělská vesnice a v nedokážu si poupravit bez pomoci nic.
Jestli jsem to dobře pobral,l je v 9 už zabezpečení proti botům pomocí capscha.
Je možný přechod z verze 7.02.06 bez problémů? všude se píše jen o přechodu z 7.02.07
RobiNN
Najprv musíš prejsť na 7.02.07 potom na 9 ale bez nejakých znalosti sa to ešte neodporúča. Ešte nie je úplne funkčný upgrade na 9.
S
tak bude lepší čistá instalace 9
Vy můžete zobrazit všechny příspěvky v tomto fóru.
Vy nemůžete začít nový diskusní příspěvek v tomto fóru.
Vy nemůžete odpovědět v této diskusi.
Vy nemůžete začít v anketu v tomto fóru.
Vy nemůžete na tomto fóru nahrát přílohy.
Vy můžete stáhnout přílohy v tomto fóru.
Uživatelé, kteří se účastnili diskuse:Kvido, RobiNN, shadou72
Nejnovější témata fóra
  Vlákno Zobrazení Odpovědi Poslední příspěvek
Přechod na PHP-fusion 8 - p...
v PHP-Fusion 8
73 2 georabbits_cz
23-01-2019 23:32
upgrade na novšie files
v Administrace nastavení
273 11 RobiNN
23-01-2019 16:46
Presunutie príspevku
v Bugy a chyby
54 2 RobiNN
23-01-2019 16:44
forum, citovať príspevok
v Bugy a chyby
50 0 Balin50
23-01-2019 11:26
Nápady - podnety
v Obecná diskuse
1082 13 RobiNN
17-01-2019 18:16
Lets Encrypt a mod_rewrite
v Administrace systému
348 10 Balin50
16-01-2019 17:52
Menu Na schválenie
v Administrace systému
267 1 RobiNN
16-01-2019 16:35
Přihlášení
Ještě nejste členem? Klikněte zde a zaregistrujte se.
Shoutbox
Chcete-li odeslat zprávu, musíte se přihlásit.
D
před 1 měsícem
Usměj se
RobiNN
před 2 měsíci
mimir na tieto veci je tu fórum...
M
před 2 měsíci
PHP 9.0 jak aktivovat registrovaného uživatele ?
C
před 2 měsíci
ahoj
Nejčtenější novinky
Žádné novinky
Žádné novinky