PHP min. 5.6.8MySQL min. 5.1Apache min. 2.0
PHP-Fusion 9 Jádro
v9.0
Český překlad
Pravidelně aktualizovaný

Technologie

Novou službu zavedl e-Portál ČSSZ; problémy na Linuxu v on-line opravě byly odstraněny

Už několik let posílám kolegovi roční Přehled ČSSZ (České správy sociálního zabezpečení) přes jeho Datovou schránku. Letos ČSSZ sdělila, že od 01.01.2015 zavádí novinku. Je to vyplnění a zaslání formuláře Přehled o příjmech a výdajích OSVČ, aktuálně za rok 2014 on-line přímo z portálu ePortálu ČSSZ. Tento způsob podporuje ideálně snadné vyplnění formuláře, včetně interaktivního, automatického předvyplňování výpočtů. Lhůta pro podání je nejpozději do jednoho měsíce ode dne, ve kterém měla OSVČ podat daňové přiznání za daný kalendářní rok (tedy letos do 4. května 2015). Tuto interaktivní samoobsluhu, která snižuje administrativní a časovou náročnost, jistě uvítá každý podnikatel. Pod platformou Windows a Mac funguje všechno stoprocentně. Na problémy jsem narazil na OS Linux/ Ubuntu 12.04.LTS.


Už několik let posílám kolegovi roční Přehled ČSSZ (České správy sociálního zabezpečení) přes jeho Datovou schránku. Letos ČSSZ sdělila, že od 01.01.2015 zavádí novinku. Je to vyplnění a zaslání formuláře Přehled o příjmech a výdajích OSVČ, aktuálně za rok 2014 on-line přímo z portálu ePortálu ČSSZ. Tento způsob podporuje ideálně snadné vyplnění formuláře, včetně interaktivního, automatického předvyplňování výpočtů. Lhůta pro podání je nejpozději do jednoho měsíce ode dne, ve kterém měla OSVČ podat daňové přiznání za daný kalendářní rok (tedy letos do 4. května 2015). Tuto interaktivní samoobsluhu, která snižuje administrativní a časovou náročnost, jistě uvítá každý podnikatel. Pod platformou Windows a Mac funguje všechno stoprocentně. Na problémy jsem narazil na OS Linux/ Ubuntu 12.04.LTS.



Technické požadavky



Jaké jsou technické požadavky pro vyplňování formulářů na ePortálu, to najdete na stránce: ePortál/Tiskopisy. Tyto požadavky, da se říct, jsou standardní. Problémy může na některém počítači způsobit absence instalace Java runtiume.



Datová schránka - odeslání formuláře/tiskopisu




Budeme se nyní věnovat odesláním formuláře (Přehled o příjmech a výdajích OSVČ) prostřednictvím datové schránky, kde musíte být samozřejmě registrovani. Do datové schránky vás dokáže ePortál automaticky přepnout, když kliknete na Přihlásit - Datová schránka. Po tomto kroku máte okamžitě k dispozici interaktivní formuláře, které poskytují službu bezprostředního odeslání datové zprávy v požadovaném formátu. Tato datová schránka je ve formuláři na ePortálu ČSSZ tudíž aktivní automaticky, nebudete ji vybírat, pouze se při odesílání přihlásíte ke své datové schránce.


Identifikátor datové schránky e-podani CSSZ: 5ffu6xk
Název datové schránky: e-podani CSSZ

Problém na Ubuntu 12.04.LTS



Na všech operačních systémech (OS), a to Windows i Mac, vyplňování tiskopisu/formuláře "Přehled" funguje stoprocentně. Na problém jsem narazil na OS Linux/Ubunti 12.04. LTS a bude zřejmě i na nejnovější verzi Ubuntu 14.04. LTS. Jak se problém projevuje? Triviálně - pod OS Ubuntu se kýžený foremulář "Přehled" neotevře!! Jak poznáme dále, šlo o triviální chybu.





  • Testujeme ePortál v prohlížeči Firefox, který pracuje na platformě OS Ubuintu 12.04 LTS. Na prohlížeči Firefox 36.0.4, Canoncial 1.0, se do ePortálu lze dostat po kliknutí na tlačítko v pravém horním rohu Datová schránka, systém otevře vstup na Datovou schránku.
  • Po vyplnění přístupových dat uživatele, se otevře Přehled o příjmech a výdajích OSVČ za rok 2014
  • Dále musíme kliknou na tlačítko Vyplnit tiskopis
    https://eportal.cssz.cz/fas/formservice/filler.open?DocID=166056200
  • Nyní by se nám měl otevřít kýžený formulář/tiskopis "Přehled". Bohužel, v Ubuntu se objeví error okno s hláškou: "Nainstalujet Java runtime" a další text: Tento formulář vyžaduje rozšířenou funkčnost. Je potřeba nainstalovat nebo zaktualizovat java runtime environment (JRE) a příslušný zásuvný modul (plug-in) do webového prohlížeče.


Formulář ePortál, OSVČ Přehled, v Ubuntu nefunguje?Formulář ePortál, OSVČ Přehled, v Ubuntu nefunguje? Jak je vidět na obrázku, okno hlásí chybu, v pozadí je vidět formulář, který se neotevřel...


Řešení problémů v Ubuntu 12.04 LTS, prohlížeč Firefox 36.0.4



Přikročil jsem tudíž k nápravným krokům. Zatím bez úspěšného výsledku. Nepomáhá Nápověda pro zobrazování v prohlížeči Firefox, která neustále hlásí, že není nainstalovaná nová verze. Nepomohla ani doinstalace nástrojů pro Ubuntu. Vše popisuji v náslewdujících krocích. Samozřčejmě, hledám příčinu vzniklé chyby.





  • Instalace balíku pro Java Runtime, Datová schránka + provoz na ČSSZ. Instalační balík „.deb“ umístěn na Ploše.

    vichvich-desktop:~$ cd ~/Plocha
    vichvich-desktop:~/Plocha$ sudo dpkg -i jre1.8.0-40_1.8.040-1_amd64.deb
    [sudo] password for vich:
    (Čtu databázi … nyní je nainstalováno 235764 souborů a adresářů.)
    Připravuji nahrazení jre1.8.0-40 1.8.040-1 (pomocí jre1.8.0-40_1.8.040-1_amd64.deb) …
    Rozbaluji náhradu jre1.8.0-40 …
    Nastavuji balík jre1.8.0-40 (1.8.040-1) …
    vichvich-desktop:~/Plocha$


    vichvich-desktop:~$ sudo -s
    [sudo] password for vich:
    rootvich-desktop:~# mkdir -p /usr/lib/mozilla/plugins
    rootvich-desktop:~# cd /usr/lib/mozilla/plugins
    rootvich-desktop:/usr/lib/mozilla/plugins# ln -s /usr/local/java/jrl.8.0/lib/amd64/libnpjp2.sorootvich-desktop:/usr/lib/mozilla/plugins#

  • Test Java: https://www.java.com/en/download/installed.jsp . Výsledek negativní. Podle Java verifikace to vypadá na pouhý problém ve FIREFOXu! Pokud je Java aktuálně nainstalována a dojde k chybě při ověřování, nasvědčuje to, že je problém v konfiguraci (např. Prohlížeč, Java ovládací panel, nastavení zabezpečení). Příčinou může být, že je Java plug blokován prohlížečem Firefox. Je nutné ověřit, zda prohlížeč podporuje Java spustit.
  • 11:00
    Pokračujeme v ověřování problému...
  • 13:05:
    Prohlížeč je OK, má přeinstalaci/upgrade na nejnovější veri 37.0. Avšak nyní je třeba ověřit verzi Java v Ubuntu. A tu se ukazuje další možná příčina nefunkčnosti formulářů v Ubuntu. OS Ubuntu 12.02 LTS má aplikaci Java runtime zastaralou, je to šestka!!! Version "1.6.0_34". Špatně!!! Ověříme tuto verzi takto:

    vichvich-desktop:~$ sudo su
    [sudo] password for vich:
    rootvich-desktop:/home/vich# java -version

    Výpis kódu:
    java version "1.6.0_34"
    OpenJDK Runtime Environment (IcedTea6 1.13.6) (6b34-1.13.6-1ubuntu0.12.04.1)
    OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)
    rootvich-desktop:/home/vich#


  • 14:45
    Po zjištění chyby, a tedy zastaralé verzi Java Instalujeme (provádíme upgrade) aktualizaci na nejnovější verzi Java "osmičku", jak to ostatně požaduje systém na ePortalu. Podařilo se bez problémů!! Ttady je výsledek, hláška o nainstalované nové verzi:

    vichvich-desktop:~$ sudo su
    [sudo] password for vich:
    rootvich-desktop:/home/vich# java -version

    Výsledek nové instalace - upgrade:
    java version "1.8.0_40"
    Java(TM) SE Runtime Environment (build 1.8.0_40-b26)
    Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)
    rootvich-desktop:/home/vich#


  • A co na to říká systém na ePortal? Zatím nevíme, ověřujeme...
  • 15:39
    DOBRÁ ZPRÁVA - FUNGUJE! range'>Tiskopisy/formuláře se na ePortalu otvírají bez problémů také v Linux/Ubuntu!!! Ve všech nejnovějších verzích Na obrázku vidíte částečný výřez z formuláře "Přehled o příjmech a výdajích OSVČ za rok 2014".


Částečný výřez formuláře ČSSZ-ePortal: Přehled o příjmech a výdajích OSVČ za rok 2014Částečný výřez formuláře ČSSZ-ePortal: Přehled o příjmech a výdajích OSVČ za rok 2014


Resumé



Nový projekt ČSSZ, elektronickou interaktivní samoobsluhu na webovém rozhraní ePortal lze označit za vynikající! Vyplnění formuláře, včetně odeslání jeho obsahu ve formátu XML přes datovou schránku, trvá přibližně šest minut! Uživatelské prostředí této služby je velmi přivětivé, není nijak komplikované. Umožňuje snadně a rychle vyplnit a odeslat "Přehledy" pro podnikatelé. A nejen to, obsahuje další množství užitečných interakitivních formulářů, což bezesporu uvítá nejen podnikatelská komunita v České republice. Popisované problémy v sysému Linux/Ubuntu byly výhradně záležitosí zastaralé instalační verze Java runtime a jejího pluginu. Jak vyplynulo z on-line opravy, které se svými podněty zúčastnili (i telefonicky) někteří čtenáři, je nutné věnovat pravidelné aktualizaci Java systému maximální pozornost. Tuto velmi důležitou aplikaci nelze přehlížet ani z bezpečnostního hlediska! V budoucnu k podobné popisované chybě jistě nedojde.








  • Autor: Květoslav (Kvido) Vícha
  • PC-politika.cz
  • Obtížnost:

02.04.2015 07:49 2,180 0 komentářů

0 komentářů

Zanechat komentář

Přihlaste se, abyste mohli zveřejnit komentář.
  • Žádné komentáře byly zveřejněny.
Nejnovější témata fóra
  Vlákno Zobrazení Odpovědi Poslední příspěvek
bugy v 9.0 - 27.4. 2017 (up...
v PHP-Fusion 9.0
354 20 RobiNN
15-08-2018 18:07
Administracia
v Administrace uživatelů
17 0 Balin50
15-08-2018 09:54
tabulka pre mobilnu verziu
v Pomoc
42 2 jany
14-08-2018 14:40
odstranenie panelov [Vyřeše...
v PHP-Fusion 9.0.3
354 16 jany
14-08-2018 13:51
cukanie menu [Vyřešeno]
v Infuze, panely, vzhledy
255 28 Kvido
14-08-2018 04:50
Šablony mailov
v Administrace nastavení
51 2 Balin50
13-08-2018 16:53
Kontrola webu
v Obecná diskuse
115 3 jany
10-08-2018 09:27