PHP min. 5.6.8MySQL min. 5.1Apache min. 2.0
GitHub
Přidejte kódy
PHP-Fusion 9 Jádro
v9.0
Český překlad
Pravidelně aktualizovaný
Demo
Testovat PHP-Fusion

Technologie

Ubuntu; aktualizace a indexové soubory

V operačním systému Linux/Ubuntu 14.04 LTS se mohou vyskytno případy, že se po startu rozsvítí výstražný trojhelník vpravo nahoře v liště . Osahuje volby pro aktualizaci, avšak ty nemusí pomoci, pokud má uživatel chybu v indexaci. Jak se problému zbavíme?

V operačním systému Linux/Ubuntu 14.04 LTS se mohou vyskytno případy, že se po startu rozsvítí výstražný trojhelník vpravo nahoře v liště . Osahuje volby pro aktualizaci, avšak ty nemusí pomoci, pokud má uživatel chybu v indexaci. Jak se problému zbavíme?

Nejprve profesní oinformaci k Linux/Ubuntu obecně, jak ji podal RRRadek Neužil, Člen občanského sdružení Ubuntu ČR a placené komunitní podpory, Administrátor fóra (parafrazuji): Od poslední aktuální verze 14.04.LTS není nutné nic ručně aktualizovat. Vše se děje automaticky, musí být však zapnutá automatická aktualizace.

Ubuntu 14.04. LTS, chyba indexace, je nutné odstranit uvedený soubor!
Ubuntu 14.04. LTS, chyba indexace, je nutné odstranit uvedený soubor!

Pokud se hlásí podobné= chyby jako na horním obrázku třeba: W: Selhalo stažení http://ppa.launchpad.net/ubuntu-x-swat/x-updates/dists//ubuntu/saucy/binary-amd64/Packages 404 Not Found W: Selhalo stažení http://ppa.launchpad.net/ubuntu-x-swat/x-updates/dists//ubuntu/saucy/binary-i386/Packages 404

Je nutné smazat ručně všechny ppa, které předtím byly přidány a již je nepoužíváte. Jinými slovy, naučit se dělat pořádek!

sudo apt-add-repository --remove ppa:ubuntu-x-swat/x-updates -y
sudo apt-get update

Může se rovněž stát, že se některé indexové soubory přesto nepodařilo stáhnout. Jsou ignorovány, případně systém použije starší verze. Pokuste se proto o opětovné upgrade zase zadáním:

sudo apt-get upgrade

Zřejmě budete mít výsledek jako na dalším obrázku:

Ubuntu 14.04 LTS, hlůáška o nedokončení indexace souiborů
Ubuntu 14.04 LTS, hláška o nedokončení indexace souiborů

Když tedy máte takový výsledek kódu, je příčina každopádně v narušení konfigurace zdrojů SW (většinou tam stačí přidat omylem nějakou nevhodnou položku). Proveďte opravu následujícím způsobem. Je odzkoušeno, expert (juwa2 - Ubuntu.cz).

  • 1. Vyprázdnění gpg cache
    sudo rm /var/lib/apt/lists/* -vf
    sudo apt-get update && sudo apt-get upgrade
    
  • 2. Odstranění všech gpg klíčů
    sudo rm /etc/apt/trusted.gpg.d/*.*
    sudo rm /etc/apt/trustdb.gpg
    sudo rm /etc/apt/trusted.gpg
    
  • 3. V okně Software & Aktualizace > karta "Ověření" kliknout na "Obnovit výchozí"
  • 4. Nakonec stáhni a nainstaluj y-ppa manager http://archive.getdeb.net/ubuntu/pool/apps/y/y-ppa-manager/y-ppa-manager_0.0.9.1-1~getdeb1_all.deb a pomocí něho nechej naiportovat všechny chybějící gpg klíče.
  • 5. Hotovo - pokud nyní zadáš do Terminálu poslední příkaz, žádná chybová hláška se už nezobrazí - všechny zdroje budou dostupné.
    sudo apt-get update
    

  • Autor: Vícha Květoslav (Kvido)
  • PC-politika.cz Zdroj: Link

Kvido 01.04.2016 08:03 445 0 komentářů

0 komentářů

Zanechat komentář

Přihlaste se, abyste mohli zveřejnit komentář.
  • Žádné komentáře byly zveřejněny.
Nejnovější témata fóra
  Vlákno Zobrazení Odpovědi Poslední příspěvek
chyba menu v paneli
v PHP - Fusion 9.0.3
34 1 Kvido
26-05-2018 17:53
obrázky v news
v PHP - Fusion 9.0.3
79 2 Balin50
24-05-2018 13:40
Gist
v Administrace obsahu
95 2 Kvido
19-05-2018 07:12
Token
v PHP - Fusion 9.0.3
102 2 Balin50
18-05-2018 12:52
Chyba - DatabaseSetup.inc
v PHP - Fusion 9.0.3
80 3 RobiNN
17-05-2018 17:46
tagy vo fóre
v PHP - Fusion 9.0.3
67 0 Balin50
16-05-2018 19:42